Support Ticket Delay
Minor
Investigating
Incident timeline
Minor
Investigating - Customers may experience a delay in our response to tickets due to a migration of our support system.
Affected:
support.servertastic.com
Investigating - Customers may experience a delay in our response to tickets due to a migration of our support system.