Service support.servertastic.com seems to be down

Major Incident support.servertastic.com
17 minutes

Update

Resolved

Service is back up.

Nov 17th, 2019 16:32 UTC
Issue

Our monitoring system has found out the service support.servertastic.com is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Nov 17th, 2019 16:15 UTC