DNS and File Authentication Details

Major incident order.servertastic.com
20 hours, 31 minutes, 46 seconds

Updates

Resolved

This issue is now resolved.

October 11, 2019 · 11:02 UTC
Monitoring

We believe this issue has been resolved by the CA. We are currently monitoring.

October 11, 2019 · 10:39 UTC
Issue

Certificates under the brands RapidSSL, Geotrust and Thawte are not returning the FILE and DNS authentication information during the order process. This is a problem with the CA system. We are able to request this information manually if you contact support.

However the CA is receiving a high support volume as a result of this issue and it is taking time to obtain this information from them

If the order is urgent the PositiveSSL and SecitigoSSL brands are unaffected.

October 10, 2019 · 14:34 UTC

← Back