Service support.servertastic.com seems to be down

Major Incident support.servertastic.com
3 minutes

Update

Resolved

Service is back up.

August 6th, 2019 at 10:29 UTC
Issue

Our monitoring system has found out the service support.servertastic.com is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

August 6th, 2019 at 10:26 UTC