Service support.servertastic.com seems to be down
Major incident
support.servertastic.com
2019-07-06 17:41 UTC
·
3 minutes, 6 seconds
Updates
Resolved
July 6, 2019 · 17:44 UTC
Service is back up.
Issue
July 6, 2019 · 17:41 UTC
Our monitoring system has found out the service support.servertastic.com is currently unresponsive, we’ll look into this now and let you know as soon as we know more.
← Back