Service order.servertastic.com seems to be down

Major Incident order.servertastic.com
3 minutes

Update

Resolved

Service is back up.

Jul 6th, 2019 17:12 UTC
Issue

Our monitoring system has found out the service order.servertastic.com is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Jul 6th, 2019 17:09 UTC