Service dashboard.servertastic.com seems to be down

Major incident dashboard.servertastic.com
2 minutes

Updates

Resolved

Service is back up.

July 6, 2019 · 16:41 UTC
Issue

Our monitoring system has found out the service dashboard.servertastic.com is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

July 6, 2019 · 16:39 UTC

← Back