Network Issues

Major incident support.servertastic.com api2.servertastic.com www.servertastic.com order.servertastic.com dashboard.servertastic.com
39 minutes, 11 seconds

Updates

Resolved

The recent DDOS affected our server network has been mitigated.

April 29, 2020 · 21:04 UTC
Issue

Customers may experience degraded performance due to an ongoing DDOS attack on our server provider.

The network team is working to continually mitigate the issue.

April 29, 2020 · 20:27 UTC

← Back